
 Activity 7.1 Worksheet 

Design Review 

Student Name: ________________________________________________  Date: _______________________  

Design Team Name: ___________________________________________  

Client Name: _________________________________________________  

Client URL: __________________________________________________  

Summary 

 After understanding the client’s goals and audience, conduct a design review of the client’s website: 

 One team member summarizes the client’s audience, purpose, and goals to confirm the group’s understanding. 

 The team evaluates the strengths of the site’s design. Consider the following design elements: 

o Consistency 

o Ease of use 

o Use of color 

o Universal navigation 

o Layout 

o Links 

o Usability 

o Accessibility 

 The team discusses improvements they would suggest to the site design. 

 One team member summarizes the strengths of the site. 

Consistency 

What elements are repeated on content pages to help identify the entire site? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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How does the repetition help or hinder the overall purpose of the website? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

When coming to the site, how do visitors know where they are, where they can go next, and whether they remain in 
the same site as they go from page to page? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

How well do the pages comply with web standards (for example, are links blue and underlined)? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

Universal Navigation 

Where is the main navigation for the site located, and how consistent is it from page to page? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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How do visitors return to the home page from every other page in the site? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

How do visitors control their movement in the site (for example, is there always a way to return to the previous page 
they visited)? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

Layout 

Is the page layout logical or does the design look randomly placed? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

How does the relative size and placement of text and images imply relative importance? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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How often do you need to scroll down the page to find important elements? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

If there are images, how clear are they? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

How do images add value to the content or are they only for decoration and appeal? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

How does the color scheme contribute to the purpose or tone of the site? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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Usability 

How clearly are links labeled? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

Is the time it takes for a page to load worth the wait? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

How easily are visitors able to find information? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

How easily are visitors able to return to essential sections of the site (if at all)? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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Accessibility 

Are all images labeled with alternative text (Alt tags)? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

To what extent are the text and titles clear and easy to read for all visitors (color, size, and so on)? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

Do image links and hotspots (image maps) have alternative text? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________
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Technical Features and Their Design Solutions 
 

Technical Feature Design Solution 

Pop-up menu Display multiple links in a small amount of space. 

Provide navigation flexibility without long download times. 

Rollover image Add highlighting or design effects with an image swap to draw visitor attention. 

Example: Buttons that change appearance when the pointer rolls over them 

Image map Help set up navigation on a website. 

Example: Geographic map with hotspots or invisible buttons that link to sites about 
each country 

Photo presentation Add design elements to pictures to enhance the overall design of the site. 

Make changes to photograph presentation elements such as tone, color, and blending. 

Spreadsheet table Quickly set up a table of information such as a directory, large catalog, or schedule. 

Calendar Quickly create an editable calendar. 

Examples: Company calendars, list of community events 

Form Interact and gather information from site visitors. 

Examples: Feedback form, guest book, survey, or product order form 

Cascading Style Sheets Create a consistent design for all pages that easily updates multiple pages on a site. 

Use with templates for managing large sites. 

Transitions, filmmaking 
effects, or timeline effects 

Enhance or reinforce the mood of the site. 

Add to overall message of the site. 

Examples: Banner ads and cartoons 

Sound Add narration to further clarify or enhance visual elements. 

Video Use video on websites to personalize and enhance the user’s experience. 

Example: Customer testimonials 
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How to Make Websites Accessible 

Alternate Text (Alt tags) 

Alternate text for images is critical for many devices that assist disabled people to access the web. The Property 
inspector in Dreamweaver has a text box for entering alternative text (Alt tag) for an image, link, or button. The text 
can be descriptive and as long as necessary, but it should be as succinct as possible. 

 

Cascading Style Sheets (CSS) 

Developers use CSS to separate content from presentation of their websites, allowing assisting devices easier access 
to the information provided in the content. Developers also use CSS to create a consistent structure for text content, 
aiding interpretive devices (such as text-to-speech browsers). 

Image Maps 

Provide alternate text for hot spots in images to make them readable by interpretive devices. 

  

Tables 

Provide alternate text descriptions for tables, such as identifiers of row and column headings for data tables or 
longer descriptions for tables with textural information. 

Templates and Library Objects 

Designers can create a single, accessible template or a small set of templates as the basis of the entire site. 
Templates limit mistakes when multiple designers are working on a site. In addition, templates foster a consistent, 
easy-to-use site that keeps visitors oriented and has consistent common elements such as navigation bars. 

Frames 

Add descriptions of frames in the Property inspector. This alternative text provides additional information to web 
browsers and readers as visitors navigate each frame. 
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Device Independence 

Use the Behaviors panel in Dreamweaver to create rollovers and other scripts that are triggered by logical events, 
such as onFocus and onBlur. Create scripts that combine mouse events with logical events to support a variety of 
visitors. 
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Sample Design Document 

Coast Middle School Website 

Project overview 

Site Challenges: 

Navigation: The page is too long, so it requires visitors to scroll. There is too much information contained under too 
few topics. For example, the About Us section could be broken into Athletics, Activities, and Volunteer 
Opportunities. 

Page Layout: Uses tables and anchor links that could be separated into multiple pages for visitors to get to all the 
information. 

Colors: The colors do not work well together and the images do not draw the interest of the audience. 

Accessibility: The main image does not have an Alt tag so a screen reader would not describe the image. 

Possible Solutions: 

Navigation: Split the page into multiple pages organized by topics, with a navigation structure on the home page. 

Page Layout: Create a new logo to replace the small picture of a schoolhouse that repeats the name of the site. 

Colors: Select two or three unifying colors to create a consistent site. 

Use technology structures such as templates and Cascading Style Sheets that will make the pages consistent and 
easy to update. 

Goals, objectives, and messages 

The Coast Middle School needs a redesign of its website to make it easier for visitors to navigate and find 
information. The present site gives information about the school location, a map, a list of teachers, and a short 
description of the school and its activities. The school uses the site to inform parents and community members about 
the school. The school’s mission is to build parental and community involvement with the school by informing them 
about volunteer activities and happenings around the school. 

Audience 

The intended audience of the site is parents, community members, school administrators, teachers, and students. 
They will go to the site for information about the school, its faculty, and its events, as well as to find more ways to 
be involved with the school. 

 Sample Design Document   7 - 35 



Activity 7.2 Guide 

Goals for redesign 

The redesign should include the following: 

 Make the site easy to update, to provide information about new school activities as well as changes in the 
faculty and staff. 

 Incorporate the new logo. 

 Give more detailed information about activities, athletics, organizations, and departments because these groups 
will be creating their own websites. 

 Use a calendar to inform the community about events at the school. 

 Give easy access to categories of information. 

 Attract the audience to increase community and parental participation in the school. 

Technical specifications (delivery requirements) 

Audience members will typically access this site by using a dial-up modem at 56Kbps or a cable modem. They 
might use Netscape Navigator, Internet Explorer, or America Online. The site should optimize all images to load 
quickly while still being appealing. 

Site content 

Home page: 

 Logo for the Coast Middle School 

 Title for the Coast Middle School 

 Links to the following areas: 

o Academics: departments, schedules, class pages, library 

o Student Activities: athletics, clubs and organizations 

o School Information: news, calendar, handbook, volunteering 

o Faculty and Staff: teachers, administrators, staff 

o About Us: mission, directory, civics, contact info, maps, links 

Sample content page: 

 Text navigation bar 

 Universal navigation to each of the following: 

o Academics 

o Student Activities 

o About Us 

o School Information 

o Faculty and Staff 

 New Coast Middle School logo 
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Site Structure 

Home Page

Academics Student Activities About Us School Information Faculty and Staff 

Library Athletics Mission News Teachers 

Class Pages Clubs Directory Calendar Administrators 

Departments Civics Handbook Staff 

Schedules Contact Info Volunteers 

Maps 

Links 
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Visual Design 

This is the original site for the Coast Middle School. It has only one page and it scrolls to include all the information 
for the school. The site is difficult to update and the text is very dense. 
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Color and Font Samples 

Design A: 

 The main blue color will be used for the navigation structure and as part of the logo. 

 The pink color will be used for regular text on the page. 

 The black and white will be used in the logo. 

 

Design B: 

 The main orange color will be used for the logo and to highlight any text. 

 The gradient blue-black will be used as a background for the navigation structure on all pages. 

 The black and white will be any text on the page: white text on the blue-black background and black text on the 
white background. 
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Sample Design Comps 

Design A 

This home page design uses pop-up menus to manage all the content and links for the main navigation. It uses the 
blue color for the navigation and a mix of blue and pink for the logo. The main text on the page is similar to the 
pink in the logo to draw the attention of the visitor. A content page would look exactly like the home page, with the 
same navigation bar across the top. For this design, the team would need to create one template for use throughout 
the site. This design unifies the site; however, it does make it difficult for visitors to know when they are on the 
home page versus a content page. 

 Consistency: The site is consistent because it uses only three colors and uses the logo and footer on every page. 

 Ease of use: Pop-up menus make the site easy to use because visitors can jump to specific information easily 
and quickly. 

 Universal navigation: A universal navigation scheme is repeated on every page. 

 Layout: The layout uses white space between the logo and the footer to focus visitor attention on the content in 
the middle of the page. 

This design uses the logo and color choice to create a simple site that might appeal to multiple audiences. 
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Design B 

This design uses a large navigation menu for the home page instead of pop-up menus. Also, a school quiz is 
included to entice visitors to learn about the Coast Middle School. The main colors and logo are used as directed. 

 
This sample content page is similar to the home page with the logo, but it contains a collapsed main navigation bar. 
Also, text links at the bottom of the page make the page more accessible. The site is unified by the logo and footer 
logo. 

 
 Consistency: This site uses color consistently, and the logo appears on every page. 

 Universal navigation: The navigation scheme is a large menu on the home page and repeats in a simpler form 
on all content pages. 

 Ease of use: The site has a main navigation scheme throughout the site and also contains text navigation at the 
bottom for visitors who have turned off viewing of graphics. 

 Layout: Layout focuses visitors on the white space between logo and footer. 

This design uses fonts and color to make the site more fun and more representative of students in a middle school. 
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Design Document 

Use this worksheet to take notes for your design document. 

Project Overview 

List site challenges. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

List possible solutions to these challenges. If you have examples from other sites that address these challenges, 
include screenshots and bibliography information. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

Goals, Objectives, and Messages 

List goals of the site. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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Audience 

Write a brief description of the target audience for this site. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

Goals for Redesign 

List the goals for redesign. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

Delivery Requirements 

List the delivery requirements (browsers, connection speed) for this site. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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Site Content  

Home page: List any images, logos, text, and links that will appear on this page. Describe any standard colors or 
fonts that must be used on this page. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 
Sample content page: List any images, logos, text, and links that will appear on this page. Describe any standard 
colors or fonts that must be used on this page. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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Site Structure 

Draw a flowchart of the site. 
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Visual Design 

Insert screenshots of the site’s original home page and a sample content page. 

Color and Font Samples 

Create two different color and font samples with Macromedia Fireworks 8 and insert screenshots of the samples. 
Describe and justify your page layout and design decisions. 

Sample Design Comps 

Create and insert screenshots of two different page designs for the home page and a content page. Use the color and 
font samples as part of these designs. Describe and justify the page layout and navigation design.
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Design Principles for Macromedia Flash Content 

When designing Macromedia Flash Content, you need to consider the following principles: 

User-Centered Design 

What you are presenting with Flash is dictated by the user, otherwise known as the audience. You must know your 
audience: how large it is, who they are, where they come from, what their goals are, and what obstacles they may 
face when accessing your Flash content. Some variables to consider include: 

 Language 

 Impairments 

 Interests 

 Experience with technology 

Purpose 

What is the main purpose of your Flash presentation? Is this for a corporate website, a software application, an 
entertainment site, a game, or for personal use? For each type of presentation, you should consider different 
technological, graphic, and usability factors. 

Consistency 

As you design the content of your presentation, create a consistent frame layout, color scheme, and navigation 
system. For example, use the same button style and menu system for all the pages on your Flash website. 

Technology

Be aware of the technical requirements it will take to implement, deliver, and access your presentation. Elements to 
consider are: 

 Hosting and ISPs 

 Web servers 

 Browser and e-mail security 

 External application needs, such as Java 

 Media playback components, such as sound cards and speakers 

Content 

The content of your site takes into consideration all other design principles. The content should be appropriate for 
your audience, align with the purpose, and be well organized, consistent in presentation, and technologically suited 
for your users. Make sure the media you include enhances your message rather than distracting from it. Increase the 
readability of text elements by applying appropriate font types, sizes, and colors. Use graphics and photographs that 
are meaningful and complement other content. 

Control 

Provide simple navigational objects for the users. Use standard designs for all buttons, scroll bars, menus, and 
language, and do not hide navigational elements. Consider accessibility guidelines when designing the navigational 
system for your presentation.
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Creating and Modifying Text in Macromedia Flash 

To create text, you can use the Text tool or you can copy and paste text from other sources. After you create the 
text, you use the Property inspector to modify attributes of the text. There are three types of text you can specify in 
the Property inspector: Static, Dynamic, and Input. The default type of text is Static. Static text is used when the text 
will not change, such as button and form labels. Dynamic text is used for text that will change, such as text pulled 
from an external database in response to user’s request. Input text is used for requesting input from the user, such as 
a user name and password. 

Create Text 

1. Start Macromedia Flash 8. 

2. Open a new Flash document. 

3. On the Timeline, double-click a Layer , name it, and 
press Enter (Windows) or Return (Macintosh). 

 Naming layers helps keep the Timeline organized. 

4. In the Tools panel, select the Text tool (Figure 1). 

5. Move the pointer to the Stage. 

 The pointer changes to a cross hair with the letter “A” 
attached to it. 

6. To create an expanding-width text field, click on the 
Stage. 

 The text field contains a flashing insertion point. This is 
where text will appear as you type. The round handle 
indicates that the text field is an expanding-width one-
line static text field (Figure 2). 

7. Type the text. 

 The text field expands as you type. 

8. Click away from the text to deselect it. 

9. To create a fixed-width text field, drag approximately a 
half inch on the Stage. 

 A text field is created. This text field has a square 
handle in the upper-right corner (Figure 3). The square 
handle indicates that the text field is a fixed-width static 
text field. 

10. Type the text. 

 The text you type wraps to a new line when it reaches 
the right edge of the text field. 

11. Drag the square handle to the right until the text is on a 
single line. 

 Note: Double-clicking a square handle changes it to a 
round handle and changes the text field to an expanding-
width one-line static text box. 

12. Click away from the text to deselect it. 

 
Figure 1 Text tool 

 

 

 

 
Figure 2 Expanding-width one-line static text 
field 

 

 

 

 
Figure 3 Fixed-width static text field 

Text tool 

Insertion point Round handle 

Square handle Insertion point 
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Edit Text 

To edit text after you create it, use the Property inspector. You can modify text attributes such as the font, font size, 
fill color, alignment, and spacing. 

 

13. Use the Text tool to select the text. 

 The text is surrounded by the text field (Figure 4). 

14. Use the Property inspector to apply text attributes 
(Figure 5). 

 Text type 

o Static: Text that does not change, such as on 
buttons, form labels, and navigation cues. This 
is the default text type. 

o Dynamic: Information that can be updated, 
such as current news generated from an 
external file or database. 

o Input: Text entered by a site visitor, such as 
personal information in completing a form. 

 Instance Name (dynamic and input text only): 
Assign a specific instance name to a text field. This 
is very useful if you want to control your text fields 
with ActionScript. 

 X and Y: Control the X and Y position of the text 
field relative to the Stage, where 0,0 is the top left 
of the Stage. 

 Width and Height: Control the width and height of 
the text field. 

 Font: Select the font to apply to the text. You can 
apply multiple font types to a single text field. 

 Font Size: Adjust the height of the text. 

 Font (fill) color: Set the color that fills each letter of 
text. 

 Alignment: Align text left, centered, right, or full. 

 Change orientation of text (static text only): Control 
vertical or horizontal positioning of text. 

 Letter spacing: Control the space between the 
letters in a text field. 

 Character positioning 

o Normal: Set text characters at the baseline. 
This is the default setting. 

o Superscript: Set text characters above the 
baseline, as for exponents. 

o Subscript: Set text characters below the 
baseline. 

 
Figure 4 Selected text 

 

 
Figure 5 Property inspector 
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 URL link (static and dynamic text only): Associate a 
website address with text. 

 Target: Control whether a URL opens in a new 
window or with a specific frame set on a page. 

 Font rendering method: Add or remove anti-alias 
on the text. Anti-alias is the smoothing of the edges 
of text to make it more readable. You have several 
options: 

o Use Device fonts: Allow the published Flash 
document to select a font from the site visitor’s 
system that closely matches the font you 
originally selected when designing the 
document. 

o Bitmap font: Useful for displaying small font 
sizes. Bitmap fonts do not contain outlines, 
which helps keep the file size of a published 
Flash document to a minimum. Bitmap fonts 
are never anti-aliased. 

o Anti-Alias for Animation: Special anti-aliasing 
for animated text. 

o Anti-Alias for Readability: Special anti-aliasing 
for text that will only be read. 

o Custom Anti-Alias: Modify thickness and 
sharpness to control the effect anti-alias has on 
your text. 

 Embed (dynamic and input text only): Control the 
character sets included in your published Flash 
document. Embedded fonts increase the file size of 
the published document. 

 Line Type (dynamic and input text only): Controls 
text wrapping in a text field. The default is single 
line spacing with no wrapping. 

 Selectable (static and dynamic text only): Allow site
visitors to select and copy the text in text fields. 

 Render Text as HTML: Retain rich-text formatting 
for text, including the HTML tags associated with 
the formatting. 

 Show Border Around Text: Turn the text field 
border on or off. 

 Variable: Assign a variable to a text field for use 
when scripting. 

 Auto Kern: Control the space between pairs of 
characters. Turning this option on uses built-in 
kerning information in the font. 
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Copy and Paste Text 

1. Start Flash and open a new Flash document. 

2. Open a file external to Flash that contains the text you 
want to copy. 

3. Select the text and copy it to the Clipboard. 

4. In Flash, create a text field on the Stage. 

5. Select Edit > Paste Special. 

 The Paste Special dialog box opens (Figure 1). 

6. Select Text (ASCII). 

7. Click OK. 

 The text is pasted in the text field you created. You can 
now format the text by using the Property inspector. 

 
Figure 1 Paste Special dialog box 
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How to Create Timeline Effects 

In Macromedia Flash 8, you can change text, shapes, and symbols in many ways. This is commonly known as 
adding effects. This guide illustrates how to apply a specific Timeline effect to text, as well as how to edit and 
remove the effect. You can apply any number of effects using this technique. 

Create a Timeline Effect 

1. Start Flash and open a new Flash document. 

2. Use the Text tool to type some text. 

3. Change some of the properties of the text, such as: 

 Font 

 Font size 

 Text Fill 

 Alignment 

 Letter Spacing 

 Character Position 

 Anti-Alias 

 Auto Kern 

4. Select the text with the Selection tool. 

5. Select Insert > Timeline Effects > Effects > 
Drop Shadow. 

 The Drop Shadow dialog box opens (Figure 1). You 
can adjust the color, transparency, and offset of the drop 
shadow. When you make changes to the settings, click 
Update Preview to preview your changes. Click OK to 
accept your settings. 

 Instead of adding a drop shadow, you have the option of 
blurring the text, expanding the text, or exploding it. 
Each effect has attributes you can set to control the 
speed, direction, color, transparency, and size of the 
effect. 

Figure 1 Drop Shadow dialog box 

Edit a Timeline Effect 

You can change an effect after you have applied it. 

6. Select the text with the effect. 

7. Select Modify > Timeline Effects > Edit Effect. 

 The dialog box opens. 

8. Change any of the settings in the dialog box and click 
OK. 
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Remove a Timeline Effect 

You can remove an effect after you have applied it. 

9. Select the text with the effect. 

10. Select Modify > Timeline Effects > Remove Effect. 

 The effect is removed. (You can restore it by selecting 
Edit > Undo.) 
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How to Use Transparent or Invisible Buttons 

Recall that the Hit state of a button is not visible. If you create a button with no graphics in the Up, Over, or Down 
states, the button will be transparent. However, you can control how a transparent button will operate when a visitor 
clicks within the hit area. You can use transparent buttons in Macromedia Flash 8 in the same way you use hot spots 
in an image map in Macromedia Dreamweaver 8. 

Create a Button 

1. Start Flash and open a new Flash document 

2. Rename Layer 1 Graphic. 

3. Insert a new layer and name it Button. 

4. On the Graphic layer, add a photo or a graphic to the 
stage. 

 The document illustrated in Figure 1 contains a photo 
of San Francisco that needs three transparent buttons to 
overlay it. Viewers can use the buttons to navigate to 
information about the subjects in the photograph. 

5. Select the Button layer. 

6. Select the Rectangle tool. 

 Choose any color for the fill. 

7. Set the Stroke Color to No color. 

8. Draw a rectangle over an area in the photograph or 
graphic to which you want to add a button (Figure 2). 

9. Select the Selection tool. 

10. Click the rectangle to select it. 

11. Select Modify > Convert to Symbol. 

12. In the Convert to Symbol dialog box, type a name for 
the button in the Name text box. 

13. Select Button as the Behavior. 

14. Click OK. 

 The button is added to the library and an instance is 
added over the photograph on the Stage. 

 
Figure 1 Transparent buttons on a photograph 

 

 

Figure 2 Rectangle drawn over hill 

 

New rectangle 
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Make a Button Transparent 

15. On the Stage, double-click the button instance. 

 The button opens in symbol-editing mode. On the 
Timeline, the Up frame is selected. 

16. Add a keyframe to the Up, Down, and Hit frames. 

17. Select the Up frame. 

18. Press Delete. 

 The colored rectangle representing the button on the 
Stage of the Up frame is deleted. 

19. Delete the colored rectangle from the Stage of the Over 
and Down frames. 

 The Hit frame should be the only frame containing a 
colored rectangle on the Stage. 

20. On the edit bar, click Scene 1. 

 The button is now transparent. 

21. Save the file. 

 

Add ActionScript 

22. Make sure the button instance is selected on the Stage. 

23. Select Window > Actions. 

 The Actions panel opens (Figure 3).  

24. At the top of the Script pane, click Script Assist. 

 The parameters area opens above the Script pane 
(Figure 4). 

25. In the Actions toolbox, click Global Functions to 
expand that category. 

26. Expand a category from which you will add the action, 
such as the Browser/Network category to have the 
button send site visitors to an external web page. 

Figure 3 Actions panel 

 

 
Figure 4 Script Assist turned on 
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 Activity 7.4 Guide 

27. Double-click getURL. 

 The getURL action is added to the Script pane. The 
parameters for getURL are displayed in the parameters 
area (Figure 5). 

28. Click in the URL text box and type a URL for your 
button to navigate to when clicked. 

 The URL is added to the getURL action in the Script 
pane. 

29. From the Window pop-up menu, select _blank 
(Figure 6). 

30. Collapse the Actions panel. 

31. Save the document. 

32. Select Control > Test Movie to test the button. 

33. Click the area of the graphic on which you created the 
invisible button. 

 A browser window opens and navigates to the website 
you defined for the button. 

Figure 5 Parameters for getURL 

 

Figure 6 URL and window type defined for the
getURL action 
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